
<!doctype html>
<html lang="en-US">
  <head>
  <meta charset="utf-8">
  <meta http-equiv="x-ua-compatible" content="ie=edge">
  <meta name="viewport" content="width=device-width, initial-scale=1">
  <title>Maxine Waters Says Putin, Er, Pence Needs to Be Impeached After Trump | NTK Network</title>

<!-- All in One SEO Pack 2.3.9.2 by Michael Torbert of Semper Fi Web Design[200,296] -->
<meta name="description"  content="The Democratic congresswoman has moved on from calling for Donald Trump's impeachment to now calling for Mike Pence's impeachment" />

<link rel="canonical" href="http://ntknetwork.com/maxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//ntknetwork.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ntknetwork.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sage/css-css'  href='http://ntknetwork.com/wp-content/themes/ntknetwork/dist/styles/main.css' type='text/css' media='all' />
<script type='text/javascript' src='http://ntknetwork.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://ntknetwork.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://ntknetwork.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ntknetwork.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ntknetwork.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Maxine Waters Leads &#8220;The View&#8221; In A Gospel Song' href='http://ntknetwork.com/maxine-waters-leads-the-view-in-a-gospel-song/' />
<link rel='next' title='$15 Minimum Wage Could Cause One Maryland County to Lose 47,000 Jobs' href='http://ntknetwork.com/15-minimum-wage-could-cause-one-maryland-county-to-lose-47000-jobs/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel='shortlink' href='http://ntknetwork.com/?p=18564' />
<link rel="alternate" type="application/json+oembed" href="http://ntknetwork.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fntknetwork.com%2Fmaxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump%2F" />
<link rel="icon" href="http://ntknetwork.com/wp-content/uploads/2016/09/cropped-testicon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="http://ntknetwork.com/wp-content/uploads/2016/09/cropped-testicon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://ntknetwork.com/wp-content/uploads/2016/09/cropped-testicon-1-180x180.png" />
<meta name="msapplication-TileImage" content="http://ntknetwork.com/wp-content/uploads/2016/09/cropped-testicon-1-270x270.png" />
  <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-79690530-1', 'auto');
  ga('send', 'pageview');
  </script>
  <!-- SOCIAL -->
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@NTKNet" />
<meta name="twitter:creator" content="@NTKNet" />


      <meta property='og:title' content='Maxine Waters Says Putin, Er, Pence Needs to Be Impeached After Trump' />
      <meta property='og:type' content='article' />
      <meta property='og:url' content='http://ntknetwork.com/maxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump/' />
      <meta property='og:image' content='http://ntknetwork.com/wp-content/uploads/2017/08/Maxine-Waters-We-Need-to-Go-After-Pence-After-Impeaching-Trump.jpg' />
      <meta property='og:description' content='The Democratic congresswoman has moved on from calling for Donald Trump&#8217;s impeachment to now calling for Mike Pence&#8217;s impeachment' />
      <meta property='twitter:description content='The Democratic congresswoman has moved on from calling for Donald Trump&#8217;s impeachment to now calling for Mike Pence&#8217;s impeachment' />
      <meta property='twitter:title' content='Maxine Waters Says Putin, Er, Pence Needs to Be Impeached After Trump' />
      <meta property='twitter:image' content='http://ntknetwork.com/wp-content/uploads/2017/08/Maxine-Waters-We-Need-to-Go-After-Pence-After-Impeaching-Trump.jpg' />
    
<!-- SOCIAL -->
  <!-- Hotjar Tracking Code for http://ntknetwork.com/ -->
  <script>
      (function(h,o,t,j,a,r){
          h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
          h._hjSettings={hjid:265531,hjsv:5};
          a=o.getElementsByTagName('head')[0];
          r=o.createElement('script');r.async=1;
          r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
          a.appendChild(r);
      })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
  </script>
  <!-- Facebook Pixel Code -->
  <script>
  !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
  n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
  document,'script','https://connect.facebook.net/en_US/fbevents.js');

  fbq('init', '1730187793900003');
  fbq('track', "PageView");</script>
  <noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=1730187793900003&ev=PageView&noscript=1"
  /></noscript>
  <!-- End Facebook Pixel Code -->
  <script type="text/javascript">
    fbq('track', 'ViewContent');
  </script>

  <!-- Google Code for Remarketing Tag -->
  <script type="text/javascript">
  /* <![CDATA[ */
  var google_conversion_id = 933302290;
  var google_custom_params = window.google_tag_params;
  var google_remarketing_only = true;
  /* ]]> */
  </script>
  <script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
  </script>
  <noscript>
  <div style="display:inline;">
  <img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/933302290/?value=0&amp;guid=ON&amp;script=0"/>
  </div>
  </noscript>
  <meta name="google-site-verification" content="gfF0RQuiJubkrBeTNixS15Fpmbt0iYcXKMCQ4f8Vvdo" />

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
googletag.cmd.push(function() {

  var leaderboard_mapping = googletag.sizeMapping().
        addSize([0, 0], []).
        addSize([730, 480], [728, 90]).
        build();

 var mobile_box_mapping = googletag.sizeMapping().
        addSize([0, 0], [300, 250]).
        addSize([1100, 480], [[300, 600], [300, 250]]).
        build();

 var only_mobile_box_mapping = googletag.sizeMapping().
        addSize([0, 0], [300, 250]).
        addSize([1100, 480],[]).
        build();

  googletag.defineSlot('/51987917/NTK_728*90', [728, 90], 'div-gpt-ad-1476365449705-5').addService(googletag.pubads()).
              defineSizeMapping(leaderboard_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

  googletag.defineSlot('/51987917/NTK_728*90_2', [728, 90], 'div-gpt-ad-1476365449705-6').addService(googletag.pubads()).
              defineSizeMapping(leaderboard_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

  googletag.defineSlot('/51987917/NTK_300*250_1', [[300, 600], [300, 250]], 'div-gpt-ad-1476365449705-1').addService(googletag.pubads()).
              defineSizeMapping(mobile_box_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

    googletag.defineSlot('/51987917/NTK_300*250_2', [[300, 600], [300, 250]], 'div-gpt-ad-1476365449705-2').addService(googletag.pubads()).
              defineSizeMapping(mobile_box_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

    googletag.defineSlot('/51987917/NTK_300*250_3', [300, 250], 'div-gpt-ad-1476365449705-3').addService(googletag.pubads()).
              defineSizeMapping(only_mobile_box_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

    googletag.defineSlot('/51987917/NTK_300*250_4', [300, 250], 'div-gpt-ad-1476365449705-4').addService(googletag.pubads()).
              defineSizeMapping(only_mobile_box_mapping).
              setCollapseEmptyDiv(true).
              addService(googletag.pubads());

    googletag.enableServices();
  });
</script>

</head>
  <body class="post-template-default single single-post postid-18564 single-format-video maxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump">
    <!--[if IE]>
      <div class="alert alert-warning">
        You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.      </div>
    <![endif]-->
    <div id="popUpWrap">
<!-- Facebook Script -->
<script type="text/javascript">
_linkedin_data_partner_id = "63515";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=63515&fmt=gif" />
</noscript>

10.132.34.32  <!-- Begin MailChimp Signup Form -->
  <div id="popUpBlack"></div>
  <div id="mc_embed_signup">
  <form action="//ntknetwork.us13.list-manage.com/subscribe/post?u=a52d8ecc92eee3f2a65a4028f&amp;id=83809e3d36" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
      <div id="mc_embed_signup_scroll">
    <h2>Subscribe to our mailing list</h2>
  <div class="mc-field-group">
    <label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
  </label>
    <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
  </div>
  <div class="mc-field-group">
    <label for="mce-MMERGE3">Name <span class="asterisk">*</span></label>
    <input type="text" value="" name="MMERGE3" class="required" id="mce-MMERGE3">
  </div>
  <div class="mc-field-group">
    <label for="mce-MMERGE1">ZIP <span class="asterisk">*</span></label>
    <input type="text" value="" name="MMERGE1" class="required" id="mce-MMERGE1">
  </div>
  <div class="mc-field-group input-group">
      <strong>What Topic Matters Most To You? </strong>
      <ul><li><input type="radio" value="Politics" name="MMERGE2" id="mce-MMERGE2-0"><label for="mce-MMERGE2-0">Politics</label></li>
  <li><input type="radio" value="Technology" name="MMERGE2" id="mce-MMERGE2-1"><label for="mce-MMERGE2-1">Technology</label></li>
  <li><input type="radio" value="Business" name="MMERGE2" id="mce-MMERGE2-2"><label for="mce-MMERGE2-2">Business</label></li>
  <li><input type="radio" value="Culture" name="MMERGE2" id="mce-MMERGE2-3"><label for="mce-MMERGE2-3">Culture</label></li>
  <li><input type="radio" value="Energy" name="MMERGE2" id="mce-MMERGE2-4"><label for="mce-MMERGE2-4">Energy</label></li>
  <li><input type="radio" value="Sports" name="MMERGE2" id="mce-MMERGE2-5"><label for="mce-MMERGE2-5">Sports</label></li>
  <li><input type="radio" value="World" name="MMERGE2" id="mce-MMERGE2-6"><label for="mce-MMERGE2-6">World</label></li>
  <li><input type="radio" value="Media" name="MMERGE2" id="mce-MMERGE2-7"><label for="mce-MMERGE2-7">Media</label></li>
  </ul>
  </div>
    <div id="mce-responses" class="clear">
      <div class="response" id="mce-error-response" style="display:none"></div>
      <div class="response" id="mce-success-response" style="display:none"></div>
    </div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
      <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a52d8ecc92eee3f2a65a4028f_83809e3d36" tabindex="-1" value=""></div>
      <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
      </div>
  </form>

  <div style="display:block; text-align:center; margin-top:-70px;"><a href="/NTK_Email_Privacy_Policy.pdf" target="_blank">View Privacy Policy</a></div>
  </div>
  <!--End mc_embed_signup-->
</div>
<header class="banner">
  <div class="container">
        <a class="brand" href="http://ntknetwork.com/">NTK Network</a>
  </div>
  <nav class="nav">
  <div class="navControl"><span class="navHam"></span></div>
    <ul>
      <li class="mobile"><a href="http://ntknetwork.com/">Home</a></li>
      <li><a href="http://ntknetwork.com/politics">Politics</a></li>
      <li><a href="http://ntknetwork.com/business">Business</a></li>
      <li><a href="http://ntknetwork.com/life">Life</a></li>
      <li class="extraMargin"><a href="http://ntknetwork.com/world">World</a></li>
      <li class="borderleft navLight"><a href="http://ntknetwork.com/about">about us</a></li>
      <li class="navLight"><a href="http://ntknetwork.com/contact">contact</a></li>
      <li id="showSignUpForm" class="navLight middleMarginMore"><a>sign up</a></li>
      <li class="navSocial firstNavSocial"><a href="https://www.facebook.com/ntknetwork/" target="_blank"><img src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/images/nav_facebook.svg" alt="NTK Network - Facebook Link" /></a></li>
      <li class="navSocial"><a href="https://twitter.com/NTKNet" target="_blank"><img src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/images/nav_twitter.svg" alt="NTK Network - Twitter Link" /></a></li>
      <li class="navSocial"><a href="https://www.instagram.com/ntknetwork/" target="_blank"><img src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/images/nav_instagram.svg" alt="NTK Network - Instagram Link" /></a></li>
      <li class="moreRightMargin navSocial"><a href="https://www.youtube.com/channel/UCJlMsN7HPbyywteQ1mk-c2Q" target="_blank"><img src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/images/nav_youtube.svg" alt="NTK Network - Youtube Link" /></a></li>
      <li><form role="search" method="get" class="search-form" action="http://ntknetwork.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;"  name="s" />
				</label>
				<button type="submit" class="search-submit"></button>
			</form></li>
    </ul>
</nav>
</header>


    <div class="document" role="document">
      <div class="modal">
        <div class="container">
          <a href="#" class="close">Close</a>
          <div class="video"></div>
          <h2 class="title"></h2>
          <div class="content"></div>
        </div>
      </div>
      <div class="wrap container content row">
                 <section class="topBar">
            
  <section class="recentPostsTop">
    <ul>
	
  	        		  <li>
          <a href="http://ntknetwork.com/spain-loves-that-trumps-new-ambassador-nominee-actually-speaks-spanish/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/08/Spain-Loves-That-Trumps-New-Ambassador-Nominee-Actually-Speaks-Spanish-1.jpg' alt=''/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">1:25 pm</span>
            </div>
            <h4 class="recentTitle">Spain Loves That Trump’s New Ambassador Nominee Actually Speaks Spanish</h4>
           <p>The nomination of Duke Buchan III as Ambassador to Spain has the Spanish media abuzz.</p>
          </a>
        </li>
        	        		  <li>
          <a href="http://ntknetwork.com/what-west-virginia-democrats-had-to-say-about-gov-jim-justice-before-last-night/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/08/What-West-Virginia-Democrats-Had-to-Say-About-Gov-Jim-Justice-Before-Last-Night-S.jpg' alt=''/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">11:14 am</span>
            </div>
            <h4 class="recentTitle">What West Virginia Democrats Had to Say About Gov. Jim Justice Before Last Night</h4>
           <p>The West Virginia Democratic Party had high praise for the governor&#8217;s efforts before he switched to the Republican Party at a Trump rally last night.</p>
          </a>
        </li>
        	        		  <li>
          <a href="http://ntknetwork.com/after-media-dems-blast-zinke-murkowski-blackmail-the-two-make-up/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/08/Murkowski_S.jpg' alt='Lisa Murkowski'/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">12:12 pm</span>
            </div>
            <h4 class="recentTitle">After Media, Dems Blast Zinke-Murkowski &#8220;Blackmail,&#8221; the Two Make Up</h4>
           <p>Media outlets and Democrats made hay out of reports that Interior Secretary Ryan Zinke threatened Sen. Lisa Murkowski (R-AK) over her health care vote. They made up this week.</p>
          </a>
        </li>
        	        		  <li>
          <a href="http://ntknetwork.com/missouri-democrat-says-shes-open-to-single-payer-health-care-system/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/02/McCaskill-s.jpg' alt=''/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">10:16 am</span>
            </div>
            <h4 class="recentTitle">Missouri Democrat Says She’s Open to Single-Payer Health Care System</h4>
           <p>Claire McCaskill indicated she could see herself supporting a “Medicare for All” single-payer health care system…</p>
          </a>
        </li>
        	        		  <li>
          <a href="http://ntknetwork.com/july-jobs-report-209k-new-u-s-jobs-trouncing-expectations/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2016/09/JobsSmall.jpg' alt='Jobs report'/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">9:13 am</span>
            </div>
            <h4 class="recentTitle">July Jobs Report: 209K New U.S. Jobs, &#8220;Trouncing Expectations&#8221;</h4>
           <p>July was another good month for jobs in the United States, according to a new report by the Bureau of Labor Statistics.</p>
          </a>
        </li>
        	        		  <li>
          <a href="http://ntknetwork.com/debbie-wasserman-schultz-defends-arrested-it-aide-imran-awan/">
          <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/08/Debbie-Wasserman-Schultz-Defends-Arrested-IT-Aide-Imran-Awan-S.jpg' alt=''/>            <div class="recentDateTimeWrap">
              <span class="recentDate">8.4.17</span>
              <span class="recentTime">8:10 am</span>
            </div>
            <h4 class="recentTitle">Debbie Wasserman Schultz Defends Arrested IT Aide Imran Awan</h4>
           <p>The former DNC chair said she stood up &#8220;for what&#8217;s right&#8221; by not firing the employee who attempted to flee Pakistan.</p>
          </a>
        </li>
        	
    </ul>
  </section>
	          </section><!-- /.topBar -->
                <main class="main">
            <article class="post-18564 post type-post status-publish format-video has-post-thumbnail hentry category-politics post_format-post-format-video">
  <div class="centerWrap">
    <!-- /51987917/NTK_728*90 -->
    <div id='div-gpt-ad-1476365449705-5'>
    <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-5'); });
    </script>
    </div>
    <header>
      <h1 class="entry-title">Maxine Waters Says Putin, Er, Pence Needs to Be Impeached After Trump</h1>
    </header>

    <div class="entry-content">
      <p>The Democratic congresswoman has moved on from calling for Donald Trump&#8217;s impeachment to now calling for Mike Pence&#8217;s impeachment</p>
    </div>
    <p><iframe src="https://www.youtube.com/embed/HPqeLLhd6gk" width="640" height="360" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
    
    
    
    <div class="share-icons">
  <a class="facebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fntknetwork.com%2Fmaxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump%2F">Facebook</a>
  <a class="twitter" target="_blank" href="https://twitter.com/home?status=Maxine+Waters+Says+Putin%2C+Er%2C+Pence+Needs+to+Be+Impeached+After+Trump%20http%3A%2F%2Fntknetwork.com%2Fmaxine-waters-says-putin-er-pence-needs-to-be-impeached-after-trump%2F">Twitter</a>
  <a class="email" href="/cdn-cgi/l/email-protection#d7e8b5b8b3aeeabfa3a3a7edf8f8b9a3bcb9b2a3a0b8a5bcf9b4b8baf8bab6afbeb9b2faa0b6a3b2a5a4faa4b6aea4faa7a2a3beb9fab2a5faa7b2b9b4b2fab9b2b2b3a4faa3b8fab5b2fabebaa7b2b6b4bfb2b3fab6b1a3b2a5faa3a5a2baa7f89ab6afbeb9b2f780b6a3b2a5a4f784b6aea4f787a2a3beb9fbf792a5fbf787b2b9b4b2f799b2b2b3a4f7a3b8f795b2f79ebaa7b2b6b4bfb2b3f796b1a3b2a5f783a5a2baa7">Mail</a>
</div>

    <div class="postDateTimeWrap">
      <div class="postDate">August 4, 2017</div>
      <div class="postTime">12:06 pm</div>
    </div>

          <div class="contentUnder">
                <p>Rep. Maxine Waters (D-CA) said that Democrats should try to impeach Vice President Mike Pence after they impeach President Trump on &#8220;The View&#8221; on Friday.</p>
<p>&#8220;Do you think Pence will be better than Trump?&#8221; host Joy Behar asked Waters.</p>
<p>&#8220;No, and when we finish with Trump, we have to go and get Putin. He&#8217;s next,&#8221; Waters said.</p>
<p>&#8220;Putin or Pence?&#8221; Behar asked, confused.</p>
<p>&#8220;Pence,&#8221; Waters said, correcting herself.</p>
<p>Waters has been calling for Trump&#8217;s impeachment since <a href="http://ntknetwork.com/maxine-waters-eventually-we-have-to-impeach-president-trump/">February</a>.</p>
      </div>
    
    
    <!--footer>
          </footer -->

    <!-- /51987917/NTK_728*90_2 -->
    <div id='div-gpt-ad-1476365449705-6'>
    <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-6'); });
    </script>
    </div>

    <!-- /51987917/NTK_300*250_3 -->
    <div id='div-gpt-ad-1476365449705-3'>
    <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-3'); });
    </script>
    </div>
    
    <div class="suggestedWrap">
      <h2>SUGGESTED POSTS</h2>
      <div class="suggestedPosts">
      <div id="rotateBack" class="sliderButton"></div>
        <div class='rpRow'>                <a href="http://ntknetwork.com/protesters-label-the-nra-racist/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/Protesters-Label-the-NRA-Racist-and-Terrorist-Here-Are-the-Facts.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  Protesters Label the NRA &#8216;Racist&#8217;                </a>
                                <a href="http://ntknetwork.com/trumps-lawyer-comey-illegally-violated-executive-privilege/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/Trumps-Lawyer-Comey-Illegally-Violated-Executive-Privilege.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  Trump&#8217;s Lawyer: Comey Illegally Violated Executive Privilege                </a>
                                <a href="http://ntknetwork.com/top-intel-dem-not-appropriate-for-democrats-to-get-help-from-ukraine/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/Top-Intel-Dem-Not-Appropriate-for-Democrats-to-Get-Help-From-Ukraine.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  Top Intel Dem: Not Appropriate for Democrats to Get Help From Ukraine                </a>
                </div><!-- .rpRow --><div class='rpRow'>                <a href="http://ntknetwork.com/donald-trumps-lawyer-nothing-illegal-about-donald-trump-jrs-meeting/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/Donald-Trumps-Lawyer-Nothing-Illegal-About-Donald-Trump-Jrs-Meeting.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  Donald Trump&#8217;s Lawyer: Nothing Illegal About Donald Trump, Jr&#8217;s Meeting                </a>
                                <a href="http://ntknetwork.com/one-in-three-americans-think-this-is-the-most-important-issue-facing-the-u-s/">
                  <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/07/PollingPlace_S.jpg' alt='A polling place'/>                  One in Three Americans Think This is the Most Important Issue Facing the U.S.                </a>
                                <a href="http://ntknetwork.com/cnn-liberal-contributor-refuses-to-say-trump-is-her-president/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/CNN-Liberal-Contributor-Refuses-to-Say-Trump-is-Her-President.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  CNN Liberal Contributor Refuses to Say Trump is Her President                </a>
                </div><!-- .rpRow --><div class='rpRow'>                <a href="http://ntknetwork.com/this-nevada-house-district-could-be-a-2018-bellwether/">
                  <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/07/RosenS.jpg' alt='Jacky Rosen'/>                  This Nevada House District Could Be a 2018 Bellwether                </a>
                                <a href="http://ntknetwork.com/new-nrsc-ad-hits-2018-dems-for-their-support-of-obamacare/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/New-NRSC-Ad-Hits-2018-Dems-for-Their-Support-of-Obamacare.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  New NRSC Ad Hits 2018 Dems for Their Support of Obamacare                </a>
                                <a href="http://ntknetwork.com/bill-clintons-chief-of-staff-says-democrats-dont-have-a-winning-message/">
                  <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/Bill-Clintons-Chief-of-Staff-Says-Democrats-Dont-Have-a-Winning-Message.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                  Bill Clinton&#8217;s Chief of Staff Says Democrats Don&#8217;t Have a Winning Message                </a>
                </div><!-- .rpRow -->        <div id="rotateForward" class="sliderButton"></div>
      </div> <!-- .suggestedPosts -->
    </div> <!-- .suggestedWrap -->
    </div> <!-- .ceterWrap -->
    <div class="rightContentSide">
     <!-- /51987917/NTK_300*250_2 -->
    <div id='div-gpt-ad-1476365449705-2'>
    <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-2'); });
    </script>
    </div>
      <div class="popularWrap">
        <h2>MOST POPULAR</h2>
        <ul>
                      <li class="popPost">
              <a href="http://ntknetwork.com/meet-the-woman-responsible-for-creating-a-network-of-over-1-million-young-conservative-women/">
                <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/07/Meet-the-Woman-Responsible-for-Creating-a-Network-of-Over-1-Million-Young-Conservative-Women-SMALL.jpg' alt=''/>                <div class="popDateTimeWrap">
                  <span class="recentDate">7.24.17</span>
                  <span class="recentTime">11:32 am</span>
                </div>
                <div class="popTitle">Meet the Woman Responsible for Creating a Network of Over 1 Million Young Conservative Women</div>
                <p>Amanda Owens started Future Female Leaders as an anonymous Twitter account, and it has grown into a community for young conservative women.</p>
              </a>
              </li>
                            <li class="popPost">
              <a href="http://ntknetwork.com/hypocrisy-alert-warren-calls-for-more-transparency-for-foreign-donations-to-campaigns/">
                <img class='hoverImage' src='http://ntknetwork.com/wp-content/uploads/2017/07/Hypocrisy-Alert-Warren-Calls-for-More-Transparency-for-Foreign-Donations-to-Campaigns-1.jpg' alt=''/>                <div class="popDateTimeWrap">
                  <span class="recentDate">7.19.17</span>
                  <span class="recentTime">8:49 pm</span>
                </div>
                <div class="popTitle">Hypocrisy Alert: Warren Calls for More Transparency for Foreign Donations to Campaigns</div>
                <p>Warren attended a fundraiser over the weekend at the home of former Wall Street executive whose company is responsible &#8220;for the greatest amount of known foreign-connected money in U.S. elections.&#8221;</p>
              </a>
              </li>
                            <li class="popPost">
              <a href="http://ntknetwork.com/rnc-chair-its-time-to-show-americans-that-the-republican-party-can-govern/">
                <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/RNC-Chairwoman-This-Is-Our-Moment-to-Repeal-and-Replace-Obamacare.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                <div class="popDateTimeWrap">
                  <span class="recentDate">7.17.17</span>
                  <span class="recentTime">3:01 pm</span>
                </div>
                <div class="popTitle">RNC Chair: It&#8217;s Time to Show Americans That the Republican Party Can Govern</div>
                <p>&#8220;Now it’s our time to show not only that we can repeal and replace Obamacare&#8230;but also that we can govern,&#8221; Ronna Romney McDaniel said during an interview on Monday.</p>
              </a>
              </li>
                            <li class="popPost">
              <a href="http://ntknetwork.com/new-nrsc-ad-hits-2018-dems-for-their-support-of-obamacare/">
                <img width="385" height="279" src="http://ntknetwork.com/wp-content/uploads/2017/07/New-NRSC-Ad-Hits-2018-Dems-for-Their-Support-of-Obamacare.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />                <div class="popDateTimeWrap">
                  <span class="recentDate">7.17.17</span>
                  <span class="recentTime">11:06 am</span>
                </div>
                <div class="popTitle">New NRSC Ad Hits 2018 Dems for Their Support of Obamacare</div>
                <p>&#8220;Democrats&#8217; Obamacare Lies,&#8221; highlights the multiple lies Senate Democrats told the American people to get Obamacare passed.</p>
              </a>
              </li>
                      </ul>
        <!-- /51987917/NTK_300*250_1 -->
        <div id='div-gpt-ad-1476365449705-1'>
        <script>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-1'); });
        </script>
        </div>
      </div>
     <!-- /51987917/NTK_300*250_3 -->
    <div id='div-gpt-ad-1476365449705-3'>
    <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-3'); });
    </script>
    </div>
      <!-- /51987917/NTK_300*250_4 -->
      <div id='div-gpt-ad-1476365449705-4'>
      <script>
      googletag.cmd.push(function() { googletag.display('div-gpt-ad-1476365449705-4'); });
      </script>
      </div>
    </div>
  </article>
        </main><!-- /.main -->
              </div><!-- /.content -->
    </div><!-- /.wrap -->
    <footer class="content-info">
  <div class="container">
    <div class="footerSignUp">
      <a href="/sign-up">SIGN UP FOR OUR NEWSLETTER</a>
    </div>
    <nav class="nav-primary">
      <div class="menu-primary-navigation-container"><ul id="menu-primary-navigation" class="nav"><li id="menu-item-24" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="http://ntknetwork.com/about-us/">About Us</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="http://ntknetwork.com/contact/">Contact</a></li>
</ul></div>      <p><a href="/">NTK Network</a> 2017    </nav>
    <div class="footerSocial"><div class="social-icons">
  <a target="_blank" class="facebook" href="https://www.facebook.com/ntknetwork/">Facebook</a>
  <a target="_blank" class="twitter" href="https://twitter.com/NTKNet">Twitter</a>
  <a target="_blank" class="instagram" href="https://www.instagram.com/ntknetwork/">Instagram</a>
	<!-- <a target="_blank" class="vine" href="https://vine.co/u/1350518569888518144">Vine</a> -->
  <a target="_blank" class="youtube" href="https://www.youtube.com/channel/UCJlMsN7HPbyywteQ1mk-c2Q">Youtube</a>
</div>
</div>
  </div>
</footer>
<script type="text/javascript">
  var j = jQuery.noConflict();
  // j(function(){
  //    j("#popUpWrap").show();
  // });
  
  j("#showSignUpForm").click(function(){
    j("#popUpWrap").show();
  });
  j("#popUpBlack").click(function(){
    j('#popUpWrap').hide();
  });
</script>
<script type='text/javascript' src='http://ntknetwork.com/wp-content/themes/ntknetwork/dist/scripts/main.js'></script>
<script type='text/javascript' src='http://ntknetwork.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
        <script type="text/javascript" src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/scripts/slider.js"></script>
        <script type="text/javascript" src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/scripts/nav.js"></script>
    <!-- <script type="text/javascript" src="http://ntknetwork.com/wp-content/themes/ntknetwork/assets/scripts/scoop.js"></script> -->
  <script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>
